Today I got Toshiba Satellite A105-S2712 for repair with the battery charging problem. It is a new model and we do not have a lot of experience with these laptops. The customer complained that the laptop will not charge the battery when it is plugged into the AC outlet.

The laptop failure symptoms:

The laptop will not turn on when I try to start it from the battery. When the laptop is turned off and plugged into the AC outlet the battery charge LED doesn’t light up. I know that the battery is not charged and the LED should light up when I plug the laptop into the AC outlet. The laptop starts fine when it is plugged. When I move the mouse over the Toshiba Power Icon in the lower right corner, the balloon will pop up and there is a line in there: Battery Remaining: N/A.

The problem repair procedure:

You can easily fix the problem just by updating the BIOS. Toshiba says that the BIOS version should be at least v1.30. So, go to Toshiba website and click on Downloads. Select your laptop model and find any downloads for the BIOS. In the BIOS change history you will see the description of changes.

After I updated the BIOS, the battery charging problem disappeared.

Support this site.

 

231 Comments

Pages: « 2411 10 9 8 7 6 5 [4] 3 2 1 » Show All

  1. 31
    Truk Says:

    I am trying to repair an l25, it was running off battery, but with an intermittent (wiggle connector) charge. It finally decided to not work at all with a dead battery. I assumed it was a loose connector and went ahead and resoldered, but I have determined that it isn’t the problem, as most of the power circuit seems to be charged. It isn’t a bios problem either. Any ideas on the problem of a way to fix it, as I can’t seem to find schematics?

  2. 30
    Sathish Says:

    I have a problem with Toshiba M105-S3041. The laptop charges intermittently though the Power cord light is always on when Power cord is on. I took it to Toshiba Service Center ( under warranty) and they changed both the motherboard and CPU. For a week it was fine, but the same problem is recurring. Also computer does not start without battery. I have updated Bios. Any suggestions to what I could do? Thank you.

  3. 29
    cj2600 Says:

    Wissam Ghanem,

    I HAVE A PROBLEM IN MY TOSHIBA TECRA A3 WHEN I PLUG THE AC CURRENT THE POWER LED FLASH AND THE BATTERY DOESNT CHARGE

    The power LED flashes orange? Does the laptop start at all from the AC adapter or from the battery? Have you tried removing the battery and starting the laptop just from the AC adapter without battery installed?

  4. 28
    cj2600 Says:

    Tan Huu Phuong,
    May be you have a corrupted or incorrect LAN driver installed and it somehow kills Windows? Can you boot to Windows in safe mode? Try uninstalling the LAN driver.
    I would probably try reloading the laptop back to original factory defaults using a recovery DVD. It might be just a software issue.

  5. 27
    WISSAM GHANEM Says:

    DIR SIR , I HAVE A PROBLEM IN MY TOSHIBA TECRA A3 WHEN I PLUG THE AC CURRENT THE POWER LED FLASH AND THE BATTERY DOESNT CHARGE SO WHEN I CHARGE THE BATTERY ON OTHER LAPTOP IT WORK S FINE TILL IT BECOMES EMPTY THANK U I HOPE I GET THE ANSWER AS SOON AS POSSIBLE
    THANK YOU

  6. 26
    Tan Huu Phuong Says:

    I Have A Toshiba Laptop A105-S4014. It is Dump when login windows. But it is ok when i disable Lan card in bios. Pls tell me how to repair it. I upgared bios.

  7. 25
    JimClarey Says:

    Firstly,
    Thanks for the immediate responses. This site is great.Secondly, I jiggle the power cord(new) for the battery(also new) but the led lights do not change. Yesterday the thing worked great all day. I do not think it an outlet problem as I take the laptop from home to work. My laptop model is 1135-S125, rather old; three years I think. Thanks for the help on here. Jim

  8. 24
    cj2600 Says:

    Jim,
    What it your laptop model? Try this. Turn on the laptop and wiggle the power plug. Can you see the LED lights flashing when you move the plug? Does the battery start charging when you wiggle the plug?
    It’s possible that your problem is related to a bad connection between the power jack and the motherboard.

  9. 23
    JimClarey Says:

    I just got a new battery and let it charge for 24 hours. At work and at home, the laptop charges intermittantly. It worked fine three days ago, now it is not charging unless the laptop is “off.” I am hesitant to download the BIOS but will go out and get the diskettes if someone on here gives me the thumbs up. Seems it is the only way to boot the laptop going by their directions. Please advise. Jim

  10. 22
    cj2600 Says:

    Brauny1,

    Help! I also have the charging problem with a L25-S1194, it is not charging the battery. I flashed the BIOS, new battery, new and correct power supply.

    I know it sucks but it looks like you have a bad motherboard. The battery connects directly to the motherboard and you already eliminated any other possible problems.

Pages: « 2411 10 9 8 7 6 5 [4] 3 2 1 » Show All

Leave a Reply